Investigating devices not accepting default ECC certificate and binary state data malformed in UI / endpoint response

Incident Report for ClearBlade

Resolved

Both issues have been resolved across all regions.
Posted Jun 24, 2026 - 19:35 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 24, 2026 - 13:20 UTC

Monitoring

ClearBlade is monitoring 2 issues uncovered after the maintenance window:
1. A small subset of devices that indicate ECC compatibility failed to accept the default ECC server certificate.
2. Binary state data appears malformed in the UI and in response to endpoint that returns states. All data is flowing to PubSub correctly.

ClearBlade has provided resolutions to both issues and is monitoring.
Posted Jun 24, 2026 - 13:19 UTC
This incident affected: ClearBlade IoT Core (Europe-West1, US-Central1, Asia-East1).